aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-08 10:40:44 +0000
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-08 10:40:44 +0000
commitf54505942ce2dcc73fcbad79d4f5cdce991bf8cb (patch)
tree9aab8e9b612adfff946a93365cd0d2fea9aeb74c /src/CMakeLists.txt
parent4a6ec712275b179decd1844232dce44bc9f9dc19 (diff)
downloadayatana-indicator-datetime-f54505942ce2dcc73fcbad79d4f5cdce991bf8cb.tar.gz
ayatana-indicator-datetime-f54505942ce2dcc73fcbad79d4f5cdce991bf8cb.tar.bz2
ayatana-indicator-datetime-f54505942ce2dcc73fcbad79d4f5cdce991bf8cb.zip
Make the datetime indicator build on non-Ubuntu systems (which mostly lack url-dispatcher and Ubuntu Touch sound schema files.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f8d219a..f0c5e28 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -44,11 +44,13 @@ set (SERVICE_CXX_SOURCES
include (GdbusCodegen)
set(SERVICE_GENERATED_SOURCES)
add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-alarm-properties
- com.canonical.indicator
- ${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.datetime.AlarmProperties.xml)
-add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-accounts-sound
- com.ubuntu.touch
- ${CMAKE_SOURCE_DIR}/src/com.ubuntu.touch.AccountsService.Sound.xml)
+ org.ayatana.indicator
+ ${CMAKE_SOURCE_DIR}/data/org.ayatana.indicator.datetime.AlarmProperties.xml)
+if(HAVE_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS)
+ add_gdbus_codegen(SERVICE_GENERATED_SOURCES dbus-accounts-sound
+ com.ubuntu.touch
+ ${CMAKE_SOURCE_DIR}/src/com.ubuntu.touch.AccountsService.Sound.xml)
+endif()
# add warnings/coverage info on handwritten files
# but not the autogenerated ones...