aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-02-22 09:40:26 -0600
committerTed Gould <ted@gould.cx>2010-02-22 09:40:26 -0600
commit56866b0fbb228fe5e7431a892d63099ee8d7c6d9 (patch)
tree54c510e1695a1fff4da28360bb91a42bfcde6b25 /src/Makefile.am
parentf595e945a2f2a12212c45213dbccf985475fee3a (diff)
downloadayatana-indicator-datetime-56866b0fbb228fe5e7431a892d63099ee8d7c6d9.tar.gz
ayatana-indicator-datetime-56866b0fbb228fe5e7431a892d63099ee8d7c6d9.tar.bz2
ayatana-indicator-datetime-56866b0fbb228fe5e7431a892d63099ee8d7c6d9.zip
Fix build to include the source files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 390f89a..bf9093d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,15 @@
+libexec_PROGRAMS = indicator-datetime-service
+
+indicator_datetime_service_SOURCES = \
+ datetime-service.c
+indicator_datetime_service_CFLAGS = \
+ -Wall \
+ -Werror \
+ $(INDICATOR_CFLAGS)
+indicator_datetime_service_LDADD = \
+ $(INDICATOR_LIBS)
+
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
libdatetime_la_SOURCES = \
@@ -11,3 +22,5 @@ libdatetime_la_LIBADD = \
libdatetime_la_LDFLAGS = \
-module \
-avoid-version
+
+EXTRA_DIST = $(libdatetime_la_SOURCES)