aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGyörgy Balló <ballogy@freestart.hu>2011-11-23 07:59:47 +0100
committerGyörgy Balló <ballogy@freestart.hu>2011-11-23 07:59:47 +0100
commit78e082682d5d833fd271899b67d6a203acffa803 (patch)
tree4abe1c6a2e6bb3414356f846086a8f18b9919c33 /src/Makefile.am
parentba87e5cb673992cee0fcb0bb3c90523974836a30 (diff)
downloadayatana-indicator-datetime-78e082682d5d833fd271899b67d6a203acffa803.tar.gz
ayatana-indicator-datetime-78e082682d5d833fd271899b67d6a203acffa803.tar.bz2
ayatana-indicator-datetime-78e082682d5d833fd271899b67d6a203acffa803.zip
Make Control Center panel optional
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 254022e..aa04900 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,8 @@
+if BUILD_CCPANEL
ccpaneldir = $(CCPANELDIR)
ccpanel_LTLIBRARIES = libindicator-datetime.la
+endif
libexec_PROGRAMS = indicator-datetime-service
@@ -42,6 +44,7 @@ libdatetime_la_LDFLAGS = \
-module \
-avoid-version
+if BUILD_CCPANEL
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \
@@ -62,6 +65,7 @@ libindicator_datetime_la_LIBADD = \
$(top_builddir)/libmap/libmap.la \
$(PREF_LIBS)
libindicator_datetime_la_LDFLAGS = -module -avoid-version
+endif
gen-%.xml.c: %.xml
@echo "Building $@ from $<"