aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-06-14 16:04:14 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-06-14 16:04:14 -0500
commitba84cae2fe41496a89cc964bc5bc0bf13c9796ed (patch)
tree71f79ab770e5d4f6bbead6a2fd463f0d4ac06418 /src/Makefile.am
parente392dd10a5dde1a0333fdeb963ecb1efecc8b19a (diff)
downloadayatana-indicator-datetime-ba84cae2fe41496a89cc964bc5bc0bf13c9796ed.tar.gz
ayatana-indicator-datetime-ba84cae2fe41496a89cc964bc5bc0bf13c9796ed.tar.bz2
ayatana-indicator-datetime-ba84cae2fe41496a89cc964bc5bc0bf13c9796ed.zip
remove build dependencies on dbusmenu, libindicator
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am37
1 files changed, 1 insertions, 36 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fee2245..31639af 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,9 +7,6 @@ endif
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
- datetime-interface.c \
- datetime-interface.h \
- gen-datetime-service.xml.c \
planner.c \
planner.h \
planner-eds.c \
@@ -27,6 +24,7 @@ indicator_datetime_service_SOURCES = \
utils.h \
dbus-shared.h \
settings-shared.h
+
indicator_datetime_service_CFLAGS = \
-Wall \
-Wextra -Wno-missing-field-initializers \
@@ -40,28 +38,6 @@ indicator_datetime_service_LDADD = \
indicator_datetime_service_LDFLAGS = \
$(COVERAGE_LDFLAGS)
-datetimelibdir = $(INDICATORDIR)
-datetimelib_LTLIBRARIES = libdatetime.la
-libdatetime_la_SOURCES = \
- gen-datetime-service.xml.h \
- dbus-shared.h \
- settings-shared.h \
- utils.c \
- utils.h \
- indicator-datetime.c
-libdatetime_la_CFLAGS = \
- $(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall -Werror \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
-libdatetime_la_LIBADD = \
- $(INDICATOR_LIBS)
-libdatetime_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module \
- -avoid-version
-
if BUILD_CCPANEL
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
@@ -93,14 +69,3 @@ gen-%.xml.c: %.xml
gen-%.xml.h: %.xml
@echo "Building $@ from $<"
@echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
-
-BUILT_SOURCES = \
- gen-datetime-service.xml.c \
- gen-datetime-service.xml.h
-
-
-CLEANFILES = \
- $(BUILT_SOURCES)
-
-EXTRA_DIST = \
- datetime-service.xml