aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-10-30 23:49:58 +0000
committerTarmac <Unknown>2013-10-30 23:49:58 +0000
commitbbc781d9e2afe500d9a5d09335f0954f25269be6 (patch)
tree87ad870ab7d39777686e4f9661bcaa4ba41b5e1d /src/Makefile.am
parent19ba64b479fd14d5192f0ec3dcc37fe33bde238b (diff)
parent13cc891202d3721fc157c827ed1141ee6221ccbd (diff)
downloadayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.tar.gz
ayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.tar.bz2
ayatana-indicator-datetime-bbc781d9e2afe500d9a5d09335f0954f25269be6.zip
Switch the build system to cmake. Fixes: https://bugs.launchpad.net/bugs/1237509.
Approved by Ted Gould, PS Jenkins bot.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am88
1 files changed, 0 insertions, 88 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index be7eb4d..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,88 +0,0 @@
-
-SHARED_CFLAGS = \
- -Wall \
- -Wextra -Wno-missing-field-initializers \
- -Werror \
- $(SERVICE_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
-
-###
-###
-###
-
-noinst_LIBRARIES = libindicator-datetime-service.a
-
-libindicator_datetime_service_a_CFLAGS = \
- $(SHARED_CFLAGS)
-
-libindicator_datetime_service_a_SOURCES = \
- clock.c \
- clock.h \
- clock-live.c \
- clock-live.h \
- planner.c \
- planner.h \
- planner-eds.c \
- planner-eds.h \
- service.c \
- service.h \
- timezone.c \
- timezone.h \
- timezone-file.c \
- timezone-file.h \
- timezone-geoclue.c \
- timezone-geoclue.h \
- utils.c \
- utils.h \
- dbus-shared.h \
- settings-shared.h
-
-###
-###
-###
-
-libexec_PROGRAMS = indicator-datetime-service
-
-indicator_datetime_service_SOURCES = \
- main.c
-
-indicator_datetime_service_CFLAGS = \
- $(SHARED_CFLAGS)
-
-indicator_datetime_service_LDADD = \
- libindicator-datetime-service.a \
- $(SERVICE_LIBS)
-
-indicator_datetime_service_LDFLAGS = \
- $(COVERAGE_LDFLAGS)
-
-###
-###
-###
-
-if BUILD_CCPANEL
-ccpaneldir = $(libdir)/control-center-1/panels/
-ccpanel_LTLIBRARIES = libindicator-datetime.la
-
-libindicator_datetime_la_SOURCES =\
- datetime-prefs.c \
- datetime-prefs-locations.c \
- datetime-prefs-locations.h \
- utils.c \
- utils.h \
- settings-shared.h
-libindicator_datetime_la_CFLAGS = \
- -Wall \
- -Werror \
- $(PREF_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DPKGDATADIR="\"$(pkgdatadir)\""
-libindicator_datetime_la_LIBADD = \
- $(PREF_LIBS)
-libindicator_datetime_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module -avoid-version
-endif