aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-09-07 09:48:46 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-09-07 09:48:46 -0500
commitecee96636e70894355aaee58675b1dbacd202ac9 (patch)
treee7ac8c31466807272285c1cd669fb12b5755b8b7 /src/Makefile.am
parentdd147887cb70a52dcba1cd26d9bbf7e29545afc4 (diff)
downloadayatana-indicator-datetime-ecee96636e70894355aaee58675b1dbacd202ac9.tar.gz
ayatana-indicator-datetime-ecee96636e70894355aaee58675b1dbacd202ac9.tar.bz2
ayatana-indicator-datetime-ecee96636e70894355aaee58675b1dbacd202ac9.zip
get coverage reports working. We now have nonzero coverage, whoo
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am83
1 files changed, 53 insertions, 30 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2f247c1..093a258 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,44 +1,67 @@
-if BUILD_CCPANEL
-ccpaneldir = $(libdir)/control-center-1/panels/
-ccpanel_LTLIBRARIES = libindicator-datetime.la
-endif
+SHARED_CFLAGS = \
+ -Wall \
+ -Wextra -Wno-missing-field-initializers \
+ -Werror \
+ $(SERVICE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
+ -DG_LOG_DOMAIN=\"Indicator-Datetime\"
+
+###
+###
+###
+
+noinst_LIBRARIES = libindicator-datetime-service.a
+
+libindicator_datetime_service_a_CFLAGS = \
+ $(SHARED_CFLAGS)
+
+libindicator_datetime_service_a_SOURCES = \
+ planner.c \
+ planner.h \
+ planner-eds.c \
+ planner-eds.h \
+ service.c \
+ service.h \
+ timezone.c \
+ timezone.h \
+ timezone-file.c \
+ timezone-file.h \
+ timezone-geoclue.c \
+ timezone-geoclue.h \
+ utils.c \
+ utils.h \
+ dbus-shared.h \
+ settings-shared.h
+
+###
+###
+###
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
- planner.c \
- planner.h \
- planner-eds.c \
- planner-eds.h \
- service.c \
- service.h \
- main.c \
- timezone.c \
- timezone.h \
- timezone-file.c \
- timezone-file.h \
- timezone-geoclue.c \
- timezone-geoclue.h \
- utils.c \
- utils.h \
- dbus-shared.h \
- settings-shared.h
+ main.c
indicator_datetime_service_CFLAGS = \
- -Wall \
- -Wextra -Wno-missing-field-initializers \
- -Werror \
- $(SERVICE_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
+ $(SHARED_CFLAGS)
+
indicator_datetime_service_LDADD = \
- $(SERVICE_LIBS)
+ libindicator-datetime-service.a \
+ $(SERVICE_LIBS)
+
indicator_datetime_service_LDFLAGS = \
- $(COVERAGE_LDFLAGS)
+ $(COVERAGE_LDFLAGS)
+
+###
+###
+###
if BUILD_CCPANEL
+ccpaneldir = $(libdir)/control-center-1/panels/
+ccpanel_LTLIBRARIES = libindicator-datetime.la
+
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
datetime-prefs-locations.c \