aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-17 15:59:12 -0600
committerTed Gould <ted@gould.cx>2012-02-17 15:59:12 -0600
commitf050e7bcb895159903d84b90d85f08901bfd3d46 (patch)
treebf23f7b1f4d852d78c7e477f18d78830f7ba9535 /src/Makefile.am
parentb18a7b815228aa5fdbfee6272fdcc621becbf3b8 (diff)
parent4b4a2a0b444d26303df7865cebb56bf942c6d022 (diff)
downloadayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.tar.gz
ayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.tar.bz2
ayatana-indicator-datetime-f050e7bcb895159903d84b90d85f08901bfd3d46.zip
Adding in code coverage calculation
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2d9a92..a31cb4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,10 +19,13 @@ indicator_datetime_service_CFLAGS = \
-Wall \
-Werror \
$(SERVICE_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
indicator_datetime_service_LDADD = \
$(SERVICE_LIBS)
+indicator_datetime_service_LDFLAGS = \
+ $(COVERAGE_LDFLAGS)
datetimelibdir = $(INDICATORDIR)
datetimelib_LTLIBRARIES = libdatetime.la
@@ -35,12 +38,14 @@ libdatetime_la_SOURCES = \
indicator-datetime.c
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-Wall -Werror \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
libdatetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
-module \
-avoid-version
@@ -56,11 +61,14 @@ libindicator_datetime_la_CFLAGS = \
-Wall \
-Werror \
$(PREF_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
-DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
libindicator_datetime_la_LIBADD = \
$(PREF_LIBS)
-libindicator_datetime_la_LDFLAGS = -module -avoid-version
+libindicator_datetime_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
endif
gen-%.xml.c: %.xml