aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMichael Terry <michael.terry@canonical.com>2011-06-28 15:32:04 +0100
committerMichael Terry <michael.terry@canonical.com>2011-06-28 15:32:04 +0100
commitf57128cae925df888e1e0cafb9ba988c665ecff8 (patch)
tree2badc6eec3bf64e8e5e650bce5064ed5aec5b095 /src/Makefile.am
parent3c5f6a06ff0e44945f788254c44ede18f4061724 (diff)
downloadayatana-indicator-datetime-f57128cae925df888e1e0cafb9ba988c665ecff8.tar.gz
ayatana-indicator-datetime-f57128cae925df888e1e0cafb9ba988c665ecff8.tar.bz2
ayatana-indicator-datetime-f57128cae925df888e1e0cafb9ba988c665ecff8.zip
update to handle latest gnome-settings-daemon dbus API for setting timezones; be more fool-proof when looking up current timezone in indicator
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6d388c7..c48cbd5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,6 +34,7 @@ libdatetime_la_SOURCES = \
libdatetime_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall -Werror \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DG_LOG_DOMAIN=\"Indicator-Datetime\"
libdatetime_la_LIBADD = \
$(INDICATOR_LIBS)
@@ -55,6 +56,7 @@ indicator_datetime_preferences_CFLAGS = \
-Werror \
-I$(top_srcdir)/libmap \
$(PREF_CFLAGS) \
+ -DTIMEZONE_FILE="\"/etc/timezone\"" \
-DPKGDATADIR="\"$(pkgdatadir)\""
indicator_datetime_preferences_LDADD = \
$(top_builddir)/libmap/libmap.la \