aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Uebernickel <lars@uebernic.de>2015-09-09 18:16:41 +0200
committerLars Uebernickel <lars@uebernic.de>2015-09-09 18:16:41 +0200
commit046cd3a7dd67935eac5f8377996423c434f44419 (patch)
tree746b0670db87e76e29a803ceb26d8cfa67466f3a /tests/CMakeLists.txt
parent60f30453fb89d3769874af42a4f24c372bcad714 (diff)
downloadayatana-indicator-datetime-046cd3a7dd67935eac5f8377996423c434f44419.tar.gz
ayatana-indicator-datetime-046cd3a7dd67935eac5f8377996423c434f44419.tar.bz2
ayatana-indicator-datetime-046cd3a7dd67935eac5f8377996423c434f44419.zip
glib-fixture: fail tests on unexpected warnings
This requires specifying which warnings are expected to be thrown (only test-timezone-file needed this for now). However, only fail on warnings in the Indicator-Datetime log domain so that we don't fail on gstreamer (or other library) warnings for now.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 032b84e..0302da9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -38,6 +38,7 @@ include_directories (${DBUSTEST_INCLUDE_DIRS})
add_definitions (-DSANDBOX="${CMAKE_CURRENT_BINARY_DIR}")
+add_definitions (-DG_LOG_DOMAIN="Indicator-Datetime")
function(add_test_by_name name)
set (TEST_NAME ${name})