aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-09-14 21:09:06 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-09-14 21:09:06 +0200
commit5df17df25d45b3fba969092a2750485b00b79a98 (patch)
treeb59701ffc8b4cc03b315ba389c671342d34caa9a /tests/CMakeLists.txt
parent68880bceab1d2a7e9f765d0867c253eddbeb4182 (diff)
parentca9dbe4b4ea579596ceeaa8a3c5c817c66b1d40a (diff)
downloadayatana-indicator-datetime-5df17df25d45b3fba969092a2750485b00b79a98.tar.gz
ayatana-indicator-datetime-5df17df25d45b3fba969092a2750485b00b79a98.tar.bz2
ayatana-indicator-datetime-5df17df25d45b3fba969092a2750485b00b79a98.zip
Merge branch 'tari01-pr/fix-focal-unit-tests'
Attributes GH PR #54: https://github.com/AyatanaIndicators/ayatana-indicator-datetime/pull/54
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index e267421..9973a39 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -41,7 +41,7 @@ function(add_test_by_name name)
add_executable (${TEST_NAME} ${TEST_NAME}.cpp gschemas.compiled)
target_link_options(${TEST_NAME} PRIVATE -no-pie)
add_test (${TEST_NAME} ${TEST_NAME})
- target_link_libraries (${TEST_NAME} indicatordatetimeservice ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBRARIES} ${GMOCK_LIBRARIES})
+ target_link_libraries (${TEST_NAME} indicatordatetimeservice ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBRARIES} ${GMOCK_LIBRARIES} ${URLDISPATCHER_LIBRARIES})
endfunction()
add_test_by_name(test-datetime)
if(HAVE_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS)
@@ -77,7 +77,7 @@ if(HAVE_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS)
set (COVERAGE_TEST_TARGETS ${COVERAGE_TEST_TARGETS} ${TEST_NAME})
add_executable (${TEST_NAME} ${TEST_NAME}.cpp)
target_link_options(${TEST_NAME} PRIVATE -no-pie)
- target_link_libraries (${TEST_NAME} indicatordatetimeservice ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBRARIES} ${GMOCK_LIBRARIES})
+ target_link_libraries (${TEST_NAME} indicatordatetimeservice ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBRARIES} ${GMOCK_LIBRARIES} ${URLDISPATCHER_LIBRARIES})
endif()
##