aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Araujo Oliveira Filho <renato.filho@canonical.com>2016-03-30 13:26:46 -0300
committerRobert Tari <robert@tari.in>2021-07-05 00:44:12 +0200
commit6105ec78d545d11184aae91700fe5aec8b8bde4b (patch)
tree4fcb0ba3d132b66de8f5f137e2f2f5e50aaeb327 /tests/CMakeLists.txt
parentba0581ac2fd8df5a5023fdc126351dafbbba07ed (diff)
downloadayatana-indicator-datetime-6105ec78d545d11184aae91700fe5aec8b8bde4b.tar.gz
ayatana-indicator-datetime-6105ec78d545d11184aae91700fe5aec8b8bde4b.tar.bz2
ayatana-indicator-datetime-6105ec78d545d11184aae91700fe5aec8b8bde4b.zip
Created unit test.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 48e2004..4b9a804 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -90,7 +90,8 @@ function(add_eds_ics_test_by_name name)
${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME} # arg2: test executable path
${TEST_NAME} # arg3: test name
${CMAKE_CURRENT_SOURCE_DIR}/test-eds-ics-config-files # arg4: base directory for config file template
- ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME}.ics) # arg5: the ical file for this test
+ ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME}.ics # arg5: the ical file for this test
+ ${CMAKE_CURRENT_SOURCE_DIR}/accounts.db) # arg6: online accounts database
endfunction()
add_eds_ics_test_by_name(test-eds-ics-all-day-events)
add_eds_ics_test_by_name(test-eds-ics-repeating-events)
@@ -100,6 +101,7 @@ add_eds_ics_test_by_name(test-eds-ics-missing-trigger)
add_eds_ics_test_by_name(test-eds-ics-tzids)
add_eds_ics_test_by_name(test-eds-ics-tzids-2)
add_eds_ics_test_by_name(test-eds-ics-tzids-utc)
+add_eds_ics_test_by_name(test-eds-ics-non-attending-alarms)
# disabling the timezone unit tests because they require
# https://code.launchpad.net/~ted/dbus-test-runner/multi-interface-test/+merge/199724