aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRatchanan Srirattanamet <ratchanan@ubports.com>2023-06-06 15:54:11 +0700
committerRobert Tari <robert@tari.in>2023-07-10 02:49:48 +0200
commitbfc2e3654b3eb4bd4d8fd336e489fe8840d7db9b (patch)
tree6e651dd8227fcdf6d99a8fafa42031edc4ae5752 /tests/CMakeLists.txt
parent3e65062b5bb0957b5bb683ff04cb658d9d530477 (diff)
downloadayatana-indicator-datetime-bfc2e3654b3eb4bd4d8fd336e489fe8840d7db9b.tar.gz
ayatana-indicator-datetime-bfc2e3654b3eb4bd4d8fd336e489fe8840d7db9b.tar.bz2
ayatana-indicator-datetime-bfc2e3654b3eb4bd4d8fd336e489fe8840d7db9b.zip
engine-eds: fix retrieving custom alarm sound path
ECal 2.0 returns the list of attachments as a GSList (a singly linked list). I'm not sure why, but the logic for iterating the list is completely incorrect. Fixing that fixes custom alarm sound. A test is added to catch this case. Bug-UBports: https://gitlab.com/ubports/development/apps/lomiri-clock-app/-/issues/183
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4b9b1d7..81eeb5d 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -108,6 +108,7 @@ add_eds_ics_test_by_name(test-eds-ics-tzids-2)
add_eds_ics_test_by_name(test-eds-ics-tzids-utc)
add_eds_ics_test_by_name(test-eds-ics-non-attending-alarms)
add_eds_ics_test_by_name(test-eds-ics-repeating-events-with-individual-change)
+add_eds_ics_test_by_name(test-eds-ics-alarm-custom-sound)
function(add_dbusmock_test_by_name name)
set (TEST_NAME ${name})