aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2015-05-21 15:24:27 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2015-05-21 15:24:27 +0000
commitc07b11f4e0b943c9f895b946e0cc84e70b603b8a (patch)
tree50cb9235c877138253b39274e88646505b182ee2 /tests/CMakeLists.txt
parent22084967d0e5ef0abbf0e2f798596f8eb6092266 (diff)
parent58efd72df90047765721c6e931da22abdb3a956a (diff)
downloadayatana-indicator-datetime-c07b11f4e0b943c9f895b946e0cc84e70b603b8a.tar.gz
ayatana-indicator-datetime-c07b11f4e0b943c9f895b946e0cc84e70b603b8a.tar.bz2
ayatana-indicator-datetime-c07b11f4e0b943c9f895b946e0cc84e70b603b8a.zip
Fix regression that caused nonrepeating alarms to go off at the wrong time. Fixes: #1456281
Approved by: PS Jenkins bot, Ted Gould
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt29
1 files changed, 15 insertions, 14 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 41efa06..1e22100 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -78,25 +78,26 @@ if(NOT EVOLUTION_SOURCE_SERVICE_NAME)
set(EVOLUTION_SOURCE_SERVICE_NAME "org.gnome.evolution.dataserver.Sources3")
endif()
-function(add_eds_test_by_name name)
+function(add_eds_ics_test_by_name name)
set (TEST_NAME ${name})
add_executable(${TEST_NAME} ${TEST_NAME}.cpp gschemas.compiled)
target_link_libraries (${TEST_NAME} indicatordatetimeservice gtest ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBS})
add_test (${TEST_NAME}
- ${CMAKE_CURRENT_SOURCE_DIR}/run-eds-test.sh
- ${DBUS_RUNNER} # arg1: dbus-test-runner exec
- ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME} # arg2: test executable path
- ${TEST_NAME} # arg3: test name
- ${EVOLUTION_CALENDAR_FACTORY} # arg4: evolution-calendar-factory exec
- ${EVOLUTION_SOURCE_SERVICE_NAME} # arg5: dbus name for source registry
- ${EVOLUTION_SOURCE_REGISTRY} # arg6: evolution-source-registry exec
- ${GVFSD} # arg7: gvfsd exec
- ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_NAME}-config-files) # arg8: canned config files
+ ${CMAKE_CURRENT_SOURCE_DIR}/run-eds-ics-test.sh
+ ${DBUS_RUNNER} # arg1: dbus-test-runner exec
+ ${CMAKE_CURRENT_BINARY_DIR}/${TEST_NAME} # arg2: test executable path
+ ${TEST_NAME} # arg3: test name
+ ${EVOLUTION_CALENDAR_FACTORY} # arg4: evolution-calendar-factory exec
+ ${EVOLUTION_SOURCE_SERVICE_NAME} # arg5: dbus name for source registry
+ ${EVOLUTION_SOURCE_REGISTRY} # arg6: evolution-source-registry exec
+ ${GVFSD} # arg7: gvfsd exec
+ ${CMAKE_CURRENT_SOURCE_DIR}/test-eds-ics-config-files # arg8: base directory for config file template
+ ${CMAKE_CURRENT_SOURCE_DIR}/${TEST_NAME}.ics) # arg9: the ical file for this test
endfunction()
-add_eds_test_by_name(test-eds-tasks)
-add_eds_test_by_name(test-eds-valarms)
-
-
+add_eds_ics_test_by_name(test-eds-ics-all-day-events)
+add_eds_ics_test_by_name(test-eds-ics-repeating-events)
+add_eds_ics_test_by_name(test-eds-ics-nonrepeating-events)
+add_eds_ics_test_by_name(test-eds-ics-repeating-valarms)
# disabling the timezone unit tests because they require