aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRatchanan Srirattanamet <ratchanan@ubports.com>2023-06-06 15:54:11 +0700
committerRatchanan Srirattanamet <ratchanan@ubports.com>2023-06-07 01:22:23 +0700
commite089a84b306ef09667752b910d87538043140042 (patch)
tree452bf4176650a2bb2d4e670619ac0d84af8b99df /tests/CMakeLists.txt
parent254bd7f76f6a3587208c8487f606b1b378b74c34 (diff)
downloadayatana-indicator-datetime-e089a84b306ef09667752b910d87538043140042.tar.gz
ayatana-indicator-datetime-e089a84b306ef09667752b910d87538043140042.tar.bz2
ayatana-indicator-datetime-e089a84b306ef09667752b910d87538043140042.zip
engine-eds: fix retrieving custom alarm sound path
ECal 2.0 returns the list of attachments as a GSList (a singly linked list). I'm not sure why, but the logic for iterating the list is completely incorrect. Fixing that fixes custom alarm sound. A test is added to catch this case. Bug-UBports: https://gitlab.com/ubports/development/apps/lomiri-clock-app/-/issues/183
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4b9b1d7..81eeb5d 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -108,6 +108,7 @@ add_eds_ics_test_by_name(test-eds-ics-tzids-2)
add_eds_ics_test_by_name(test-eds-ics-tzids-utc)
add_eds_ics_test_by_name(test-eds-ics-non-attending-alarms)
add_eds_ics_test_by_name(test-eds-ics-repeating-events-with-individual-change)
+add_eds_ics_test_by_name(test-eds-ics-alarm-custom-sound)
function(add_dbusmock_test_by_name name)
set (TEST_NAME ${name})