aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-11-06 18:28:32 -0600
committerCharles Kerr <charles.kerr@canonical.com>2012-11-06 18:28:32 -0600
commit7ebd1bec24a732a0f7069e727ff4036f6b925e99 (patch)
treea6c0d6c2b9e04ce2e93612a947f2d390045aea7e /tests/Makefile.am
parentab006f93c2bf00a3bb7b33cebf26a12e46821fbb (diff)
downloadayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.tar.gz
ayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.tar.bz2
ayatana-indicator-datetime-7ebd1bec24a732a0f7069e727ff4036f6b925e99.zip
add Google Test scaffolding to indicator-datetime: autotools rules, support for finding the uninstalled copy of the gsettings schema, and a 'hello world' test.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e69de29..cc3b52a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -0,0 +1,52 @@
+TESTS =
+CLEANFILES =
+BUILT_SOURCES =
+check_PROGRAMS =
+
+###
+###
+###
+
+# stock UMB tests on user-visible strings
+include $(srcdir)/Makefile.am.strings
+
+check_LIBRARIES = libgtest.a
+nodist_libgtest_a_SOURCES = \
+ $(GTEST_SOURCE)/src/gtest-all.cc \
+ $(GTEST_SOURCE)/src/gtest_main.cc
+
+AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
+AM_CXXFLAGS = $(GTEST_CXXFLAGS)
+
+###
+###
+###
+
+TEST_LIBS = \
+ $(top_builddir)/src/.libs/libdatetime.so \
+ $(INDICATOR_LIBS) \
+ $(COVERAGE_LDFLAGS) \
+ libgtest.a
+
+TEST_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ $(INDICATOR_CFLAGS)
+
+BUILT_SOURCES += gschemas.compiled
+CLEANFILES += gschemas.compiled
+gschemas.compiled: Makefile
+ @glib-compile-schemas --targetdir=$(abs_builddir) $(top_builddir)/data
+
+###
+###
+###
+
+TESTS += test-indicator
+check_PROGRAMS += test-indicator
+test_indicator_SOURCES = test-indicator.cc
+test_indicator_LDADD = $(TEST_LIBS)
+test_indicator_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""
+
+###
+###
+###