aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorIain Lane <iain@orangesquash.org.uk>2013-06-13 11:54:37 +0100
committerIain Lane <iain@orangesquash.org.uk>2013-06-13 11:54:37 +0100
commitadcf6754fb52a1dd9ed099fe420eebbb4fcbb082 (patch)
tree5e0b588637d5ddd7cce20c73d7bba3c19ce51e58 /tests/Makefile.am
parent397f360c08ce59b44ae51038f07e2b4e44b7279c (diff)
downloadayatana-indicator-datetime-adcf6754fb52a1dd9ed099fe420eebbb4fcbb082.tar.gz
ayatana-indicator-datetime-adcf6754fb52a1dd9ed099fe420eebbb4fcbb082.tar.bz2
ayatana-indicator-datetime-adcf6754fb52a1dd9ed099fe420eebbb4fcbb082.zip
Link test program in the right order. Importantly, make sure
XORG_GTEST_LIBS comes after it as it uses pthread.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ca0cbc..f9676c3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,10 +24,10 @@ AM_CXXFLAGS = $(GTEST_CXXFLAGS)
TEST_LIBS = \
$(top_builddir)/src/.libs/libdatetime.so \
+ libgtest.a \
$(INDICATOR_LIBS) \
$(COVERAGE_LDFLAGS) \
- $(XORG_GTEST_LDFLAGS) \
- libgtest.a
+ $(XORG_GTEST_LDFLAGS)
TEST_CPPFLAGS = \
$(AM_CPPFLAGS) \