aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-10-31 11:40:41 -0700
committerTed Gould <ted@gould.cx>2013-10-31 11:40:41 -0700
commiteb47d698341bc8f1b46433c48fc280d5a4906ad3 (patch)
tree04e18a96bcad6c22f5079a517c5c8927d1ac49cd /tests/Makefile.am
parenta4a5562fd93fdd6d9cb4b9cde98126fdca3ea21d (diff)
parent0439dc69bfd71c42d01b7d11cb586ef056503b28 (diff)
downloadayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.tar.gz
ayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.tar.bz2
ayatana-indicator-datetime-eb47d698341bc8f1b46433c48fc280d5a4906ad3.zip
Merge trunk
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am58
1 files changed, 0 insertions, 58 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
deleted file mode 100644
index e204378..0000000
--- a/tests/Makefile.am
+++ /dev/null
@@ -1,58 +0,0 @@
-TESTS =
-CLEANFILES =
-BUILT_SOURCES =
-check_PROGRAMS =
-
-###
-###
-###
-
-# stock UMB tests on user-visible strings
-include $(srcdir)/Makefile.am.strings
-
-check_LIBRARIES = libgtest.a
-nodist_libgtest_a_SOURCES = \
- $(GTEST_SOURCE)/gtest-all.cc \
- $(GTEST_SOURCE)/gtest_main.cc
-
-AM_CPPFLAGS = $(GTEST_CPPFLAGS) -I${top_srcdir}/src -Wall -Werror
-AM_CXXFLAGS = $(GTEST_CXXFLAGS)
-
-###
-###
-###
-
-TEST_LIBS = \
- libgtest.a \
- $(SERVICE_LIBS) \
- $(COVERAGE_LDFLAGS) \
- $(XORG_GTEST_LDFLAGS)
-
-TEST_CPPFLAGS = \
- $(AM_CPPFLAGS) \
- $(SERVICE_CFLAGS)
-
-BUILT_SOURCES += gschemas.compiled
-CLEANFILES += gschemas.compiled
-gschemas.compiled: Makefile
- @glib-compile-schemas --targetdir=$(abs_builddir) $(top_builddir)/data
-
-###
-###
-###
-
-TESTS += test-indicator
-check_PROGRAMS += test-indicator
-test_indicator_SOURCES = test-indicator.cc
-test_indicator_LDADD = $(TEST_LIBS)
-test_indicator_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""
-
-###
-###
-###
-
-TESTS += test-utils
-check_PROGRAMS += test-utils
-test_utils_SOURCES = test-utils.cc
-test_utils_LDADD = $(top_builddir)/src/libindicator-datetime-service.a $(TEST_LIBS)
-test_utils_CPPFLAGS = $(TEST_CPPFLAGS) -DSCHEMA_DIR="\"$(top_builddir)/tests/\""