aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3cf45ef..2418f12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,15 +113,18 @@ AS_IF([test "x$with_gtk" = x3],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
+# FIXME: polkit-gtk-1 isn't gtk3-compatible
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-3.0 >= $GTK3_REQUIRED_VERSION
- unique-3.0)
+ unique-3.0
+ polkit-gtk-1)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(PREF, gio-2.0 >= $GIO_REQUIRED_VERSION
gtk+-2.0 >= $GTK_REQUIRED_VERSION
- unique-1.0)
+ unique-1.0
+ polkit-gtk-1)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)