aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f98cf93
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@ --with quilt,autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_auto_configure:
+ dh_auto_configure -- --disable-static
+
+override_dh_install:
+ find debian/indicator-datetime -name \*.la -delete
+ find debian/indicator-datetime -name \*.a -delete
+ cd po; intltool-update --pot --verbose
+ dh_install --fail-missing
+ # Language packs
+ for d in $$(find debian/indicator-datetime -type f \( -name "*.desktop" -o -name "*.directory" \) ); do \
+ sed -ri '/^(Name|GenericName|Comment|X-GNOME-FullName)\[/d' $$d; \
+ echo "X-Ubuntu-Gettext-Domain=indicator-datetime" >> $$d; \
+ done;
+