aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control14
-rwxr-xr-xdebian/rules2
2 files changed, 9 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index df4d39f..0ede198 100644
--- a/debian/control
+++ b/debian/control
@@ -19,15 +19,15 @@ Build-Depends: cmake,
liblomiri-url-dispatcher-dev | hello,
libproperties-cpp-dev,
# for the test harness:
- libgtest-dev,
- libdbustest1-dev,
- dbus-test-runner,
- python3-dbusmock,
+ libgtest-dev <!nocheck>,
+ libdbustest1-dev <!nocheck>,
+ dbus-test-runner <!nocheck>,
+ python3-dbusmock <!nocheck>,
# for 12h/24h locale unit tests:
- locales,
+ locales <!nocheck>,
# for running live EDS tests:
- evolution-data-server,
- gvfs-daemons,
+ evolution-data-server <!nocheck>,
+ gvfs-daemons <!nocheck>,
systemd [linux-any],
# for phone alarm/calendar notification sound tests:
ubuntu-touch-sounds | hello,
diff --git a/debian/rules b/debian/rules
index 37eb8b7..0a1b6f7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,10 @@ LDFLAGS += -Wl,-z,defs -Wl,--as-needed
%:
dh $@ --with systemd
+ifneq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
override_dh_auto_configure:
dh_auto_configure -- -Denable_tests=OFF
+endif
override_dh_install:
dh_install --fail-missing