aboutsummaryrefslogtreecommitdiff
path: root/panel-unity/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'panel-unity/CMakeLists.txt')
-rw-r--r--panel-unity/CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/panel-unity/CMakeLists.txt b/panel-unity/CMakeLists.txt
deleted file mode 100644
index c8ebde0..0000000
--- a/panel-unity/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-set (PANEL_LIB "unity-indicator-datetime")
-
-add_definitions (-DPKGDATADIR="${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/${CMAKE_PROJECT_NAME}")
-
-SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -g")
-SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -g ${CXX_WARNING_ARGS}")
-
-add_library (${PANEL_LIB} SHARED
- ${CMAKE_SOURCE_DIR}/panel/datetime-prefs.c
- ${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.c
- ${CMAKE_SOURCE_DIR}/panel/datetime-prefs-locations.h
- ${CMAKE_SOURCE_DIR}/src/utils.c
- ${CMAKE_SOURCE_DIR}/include/datetime/utils.h
- ${CMAKE_SOURCE_DIR}/include/datetime/settings-shared.h)
-set_property (TARGET ${PANEL_LIB} PROPERTY OUTPUT_NAME indicator-datetime)
-
-include_directories (SYSTEM ${UNITY_PANEL_DEPS_INCLUDE_DIRS})
-
-link_directories (${UNITY_PANEL_DEPS_LIBRARY_DIRS})
-
-set_property (TARGET ${PANEL_LIB}
- APPEND_STRING PROPERTY COMPILE_FLAGS
- " -g ${CC_WARNING_ARGS} ${GCOV_FLAGS} -DUSE_UNITY")
-
-target_link_libraries (${PANEL_LIB} ${UNITY_PANEL_DEPS_LIBRARIES} ${GCOV_LIBS})
-
-install (TARGETS ${PANEL_LIB}
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/unity-control-center-1/panels)
-