aboutsummaryrefslogtreecommitdiff
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 8325f6e..e78a9df 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,3 +1,12 @@
-include (Translations)
-add_translations_directory ("${GETTEXT_PACKAGE}")
-add_translations_catalog ("${GETTEXT_PACKAGE}" ../src/)
+find_package(Intltool REQUIRED)
+
+intltool_update_potfile(
+ KEYWORDS "_" "_:1,2" "N_" "N_:1,2"
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+ COPYRIGHT_HOLDER "Canonical Ltd."
+)
+
+intltool_install_translations(
+ ALL
+ GETTEXT_PACKAGE ${GETTEXT_PACKAGE}
+)