aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am62
1 files changed, 15 insertions, 47 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a31cb4b..7143c6b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,16 +7,27 @@ endif
libexec_PROGRAMS = indicator-datetime-service
indicator_datetime_service_SOURCES = \
- datetime-interface.c \
- datetime-interface.h \
- gen-datetime-service.xml.c \
- datetime-service.c \
+ planner.c \
+ planner.h \
+ planner-eds.c \
+ planner-eds.h \
+ service.c \
+ service.h \
+ main.c \
+ timezone.c \
+ timezone.h \
+ timezone-file.c \
+ timezone-file.h \
+ timezone-geoclue.c \
+ timezone-geoclue.h \
utils.c \
utils.h \
dbus-shared.h \
settings-shared.h
+
indicator_datetime_service_CFLAGS = \
-Wall \
+ -Wextra -Wno-missing-field-initializers \
-Werror \
$(SERVICE_CFLAGS) \
$(COVERAGE_CFLAGS) \
@@ -27,28 +38,6 @@ indicator_datetime_service_LDADD = \
indicator_datetime_service_LDFLAGS = \
$(COVERAGE_LDFLAGS)
-datetimelibdir = $(INDICATORDIR)
-datetimelib_LTLIBRARIES = libdatetime.la
-libdatetime_la_SOURCES = \
- gen-datetime-service.xml.h \
- dbus-shared.h \
- settings-shared.h \
- utils.c \
- utils.h \
- indicator-datetime.c
-libdatetime_la_CFLAGS = \
- $(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall -Werror \
- -DTIMEZONE_FILE="\"/etc/timezone\"" \
- -DG_LOG_DOMAIN=\"Indicator-Datetime\"
-libdatetime_la_LIBADD = \
- $(INDICATOR_LIBS)
-libdatetime_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module \
- -avoid-version
-
if BUILD_CCPANEL
libindicator_datetime_la_SOURCES =\
datetime-prefs.c \
@@ -70,24 +59,3 @@ libindicator_datetime_la_LDFLAGS = \
$(COVERAGE_LDFLAGS) \
-module -avoid-version
endif
-
-gen-%.xml.c: %.xml
- @echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
- @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- @echo ";" >> $@
-
-gen-%.xml.h: %.xml
- @echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
-
-BUILT_SOURCES = \
- gen-datetime-service.xml.c \
- gen-datetime-service.xml.h
-
-
-CLEANFILES = \
- $(BUILT_SOURCES)
-
-EXTRA_DIST = \
- datetime-service.xml