aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-01-12 00:08:42 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-04 23:43:05 +0100
commit0db5d4e7d671ff8af9b5905d111851e608c842c2 (patch)
tree4cecdde71ae52965941c90de10225964465169bd /CMakeLists.txt
parent2d4a7321471115bc04687296811687c8797a54b6 (diff)
downloadayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.tar.gz
ayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.tar.bz2
ayatana-indicator-display-0db5d4e7d671ff8af9b5905d111851e608c842c2.zip
Implement adaptive colour temperature profiles
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f04d4aa..c8fdcd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
option(ENABLE_LOMIRI_FEATURES "Build with Lomiri-specific libraries, schemas and media" OFF)
+option(ENABLE_COLOR_TEMP "Include colour temperature specific code in the build" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -78,6 +79,11 @@ if (ENABLE_LOMIRI_FEATURES)
add_definitions (-DLOMIRI_FEATURES_ENABLED)
endif ()
+if (ENABLE_COLOR_TEMP)
+ list (APPEND SERVICE_DEPS libgeoclue-2.0)
+ add_definitions (-DCOLOR_TEMP_ENABLED)
+endif ()
+
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})
include_directories (SYSTEM
@@ -123,3 +129,4 @@ message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")
message(STATUS "Build with Lomiri features: ${ENABLE_LOMIRI_FEATURES}")
+message(STATUS "Build with colour temperature code: ${ENABLE_COLOR_TEMP}")