aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2024-06-25 13:01:52 +0200
committerRobert Tari <robert@tari.in>2024-07-08 14:58:40 +0200
commit34ef083efff477dd8b2af7ce415f837969f246e1 (patch)
treeeff5d61e50787958700929faffd646200bac4daf /CMakeLists.txt
parentede1f56b9a0d1b3e47fe8c8bca0e2444c6d28458 (diff)
downloadayatana-indicator-display-34ef083efff477dd8b2af7ce415f837969f246e1.tar.gz
ayatana-indicator-display-34ef083efff477dd8b2af7ce415f837969f246e1.tar.bz2
ayatana-indicator-display-34ef083efff477dd8b2af7ce415f837969f246e1.zip
Hide xsct features if not supported by server/driver
fixes https://github.com/AyatanaIndicators/ayatana-indicator-display/issues/70
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e711b4b..bdde653 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
option(ENABLE_COLOR_TEMP "Include colour temperature specific code in the build" ON)
+option(ENABLE_RDA "Enable RDA (remote desktop awareness), only taking effect if built with ENABLE_COLOR_TEMP" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -68,8 +69,13 @@ set(GLIB_MINIMUM 2.36)
set (SERVICE_DEPS libayatana-common>=0.9.3 gio-unix-2.0>=${GLIB_MINIMUM} glib-2.0>=${GLIB_MINIMUM} properties-cpp>=0.0.1)
if (ENABLE_COLOR_TEMP)
- list (APPEND SERVICE_DEPS libgeoclue-2.0 accountsservice)
+ list (APPEND SERVICE_DEPS libgeoclue-2.0 accountsservice x11 xrandr)
add_definitions (-DCOLOR_TEMP_ENABLED)
+
+ if (ENABLE_RDA)
+ list (APPEND SERVICE_DEPS rda)
+ add_definitions (-DRDA_ENABLED)
+ endif ()
endif ()
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})
@@ -117,3 +123,4 @@ message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")
message(STATUS "Build with colour temperature code: ${ENABLE_COLOR_TEMP}")
+message(STATUS "Build with remote desktop awareness: ${ENABLE_RDA}")