aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-24 12:27:07 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-24 12:27:07 +0200
commitb49abfb17a3073a52711755b0e4147b9ca35f941 (patch)
tree351df24edb3d678963da0178936b24f561d13b54 /CMakeLists.txt
parent2ca072ab8af352e110747d11e685db7edcd09bb2 (diff)
downloadayatana-indicator-display-b49abfb17a3073a52711755b0e4147b9ca35f941.tar.gz
ayatana-indicator-display-b49abfb17a3073a52711755b0e4147b9ca35f941.tar.bz2
ayatana-indicator-display-b49abfb17a3073a52711755b0e4147b9ca35f941.zip
CMakeLists.txt: Drop workaround for missing libexec dir on Debian. Debian moved forward and now supports FHS 3.0 (since Debian Policy 4.1.5).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10d3472..886b529 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,10 +12,6 @@ set(SERVICE_EXEC "${PACKAGE}-service")
##
include(GNUInstallDirs)
-if(EXISTS "/etc/debian_version") # Workaround for libexecdir on debian
- set(CMAKE_INSTALL_LIBEXECDIR "${CMAKE_INSTALL_LIBDIR}")
- set(CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
-endif()
set(CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
set(CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")