aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-03-06 23:00:42 -0600
committerCharles Kerr <charles.kerr@canonical.com>2016-03-06 23:00:42 -0600
commitd911528cfb367fac34a5764ad6bce339a12f56d0 (patch)
tree32b787f791508173b3322c21fe029fa3c44cc9db /CMakeLists.txt
parent8cf3f1a9b4e9d102dfeaf5fcfa7bc4a43711d0ae (diff)
downloadayatana-indicator-display-d911528cfb367fac34a5764ad6bce339a12f56d0.tar.gz
ayatana-indicator-display-d911528cfb367fac34a5764ad6bce339a12f56d0.tar.bz2
ayatana-indicator-display-d911528cfb367fac34a5764ad6bce339a12f56d0.zip
add ADB server/client + tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a35d95..9fa4d10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ set (SERVICE_EXEC "${PACKAGE}-service")
option (enable_tests "Build the package's automatic tests." ON)
option (enable_lcov "Generate lcov code coverage reports." ON)
+set(THREADS_PREFER_PTHREAD_FLAG ON)
+find_package(Threads REQUIRED)
+
##
## GNU standard paths
##
@@ -47,7 +50,7 @@ include_directories (${CMAKE_CURRENT_SOURCE_DIR})
# set the compiler warnings
if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set (CXX_WARNING_ARGS "${CXX_WARNING_ARGS} -Weverything -Wno-c++98-compat")
+ set (CXX_WARNING_ARGS "${CXX_WARNING_ARGS} -Weverything -Wno-c++98-compat -Wno-padded")
else()
set (CXX_WARNING_ARGS "${CXX_WARNING_ARGS} -Wall -Wextra -Wpedantic")
endif()