aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:52:30 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:52:30 +0100
commiteb1bd990194bdf5eecd6918b4337d29a13d823f7 (patch)
tree78b33cc4f38a737f716cc0c763a3a2f2b2ed40da /debian
parentd8d6fd6855d3a9d0101a9d0226e95958508fcb9c (diff)
downloadayatana-indicator-display-eb1bd990194bdf5eecd6918b4337d29a13d823f7.tar.gz
ayatana-indicator-display-eb1bd990194bdf5eecd6918b4337d29a13d823f7.tar.bz2
ayatana-indicator-display-eb1bd990194bdf5eecd6918b4337d29a13d823f7.zip
debian/{control,postinst}: Recompile GSettings schemas at post installation.
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/postinst40
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index e477902..9dd4cb7 100644
--- a/debian/control
+++ b/debian/control
@@ -34,6 +34,7 @@ Architecture: any
Depends: ${shlibs:Depends},
${misc:Depends},
ayatana-indicator-common,
+ glib2.0-bin,
Description: Ayatana Indicator for Display configuration
This Ayatana Indicator is designed to be placed on the right side of a
panel and give the user easy control for changing their display settings.
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..f98fc62
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,40 @@
+#!/bin/sh
+# postinst script for ayatana-indicator-display
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0