aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-03-08 13:08:07 -0600
committerCharles Kerr <charles.kerr@canonical.com>2016-03-08 13:08:07 -0600
commit40f48471fe531ba5b9f1e1c4371f252fca4c2d52 (patch)
treefccbe9bd02bce73f34c249bf5f1e7704fcbf2738 /src/CMakeLists.txt
parent95277f3c7344e537ad42835c64607339e1d3e6e9 (diff)
downloadayatana-indicator-display-40f48471fe531ba5b9f1e1c4371f252fca4c2d52.tar.gz
ayatana-indicator-display-40f48471fe531ba5b9f1e1c4371f252fca4c2d52.tar.bz2
ayatana-indicator-display-40f48471fe531ba5b9f1e1c4371f252fca4c2d52.zip
add out-of-line virtual method definitions to Indicator to silence clang++ warnings
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 414a750..ff385d9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,7 +7,9 @@ add_definitions (-DG_LOG_DOMAIN="${CMAKE_PROJECT_NAME}")
set (SERVICE_LIB_HANDWRITTEN_SOURCES
adbd-client.cpp
exporter.cpp
- rotation-lock.cpp)
+ indicator.cpp
+ rotation-lock.cpp
+ usb-snap.cpp)
add_library (${SERVICE_LIB} STATIC
${SERVICE_LIB_HANDWRITTEN_SOURCES})