aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-10-25 17:26:42 +0200
committerRobert Tari <robert@tari.in>2021-10-25 17:26:42 +0200
commit03d55a301614654bf150f51c0e0c472fef6a904b (patch)
tree852419cff072412f807e4be0fb099a2802987b86 /tests/CMakeLists.txt
parentdb6cef87656a54dafa3fea9c588f54281512e665 (diff)
parent313410a372dc87943bd1b5045ab29bd4a00daf9d (diff)
downloadayatana-indicator-display-03d55a301614654bf150f51c0e0c472fef6a904b.tar.gz
ayatana-indicator-display-03d55a301614654bf150f51c0e0c472fef6a904b.tar.bz2
ayatana-indicator-display-03d55a301614654bf150f51c0e0c472fef6a904b.zip
Merge branch 'sunweaver-pr/travis-cleanup'
Attributes GH PR #34: https://github.com/AyatanaIndicators/ayatana-indicator-display/pull/34
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 76ebd56..4c1b9b8 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -29,7 +29,7 @@ endif()
add_compile_options(${CXX_WARNING_ARGS})
-add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression)
+add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression --suppress=constParameter)
add_subdirectory(integration)
add_subdirectory(unit)