aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2024-05-17 16:10:34 +0200
committerRobert Tari <robert@tari.in>2024-05-17 16:10:34 +0200
commit4b25c3a134abb60fbd1b3b360d5d877d3b075aa5 (patch)
tree3f6230564568451c0e4c5357c37f4cc47cdab195 /tests/CMakeLists.txt
parent9a605aa2479f99a088fa079ba12a9e86da165166 (diff)
parentbfb74193db0e172bb1db5fc837a4b1ee4688259f (diff)
downloadayatana-indicator-display-4b25c3a134abb60fbd1b3b360d5d877d3b075aa5.tar.gz
ayatana-indicator-display-4b25c3a134abb60fbd1b3b360d5d877d3b075aa5.tar.bz2
ayatana-indicator-display-4b25c3a134abb60fbd1b3b360d5d877d3b075aa5.zip
Merge branch 'sunweaver-pr/cppcheck-2.14'
Attributes GH PR #96: https://github.com/AyatanaIndicators/ayatana-indicator-display/pull/96
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 81e083c..bdc074f 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -28,7 +28,7 @@ endif()
add_compile_options(${CXX_WARNING_ARGS})
-add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression --suppress=constParameter --suppress=unusedFunction --suppress=uselessOverride)
+add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --check-level=exhaustive --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression --suppress=constParameter --suppress=constParameterCallback --suppress=unusedFunction --suppress=uselessOverride)
add_subdirectory (unit)