aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-08-12 21:03:34 +0200
committerRobert Tari <robert@tari.in>2021-08-12 21:15:38 +0200
commite66c68e2420ed2e2b4ce531dea46dc04b3db297b (patch)
tree702bd2bc84523c6949042d98de7413261af87455 /tests/CMakeLists.txt
parent7db2204cc52bfc30fe40d22b69239b8fb6c3cd11 (diff)
downloadayatana-indicator-display-e66c68e2420ed2e2b4ce531dea46dc04b3db297b.tar.gz
ayatana-indicator-display-e66c68e2420ed2e2b4ce531dea46dc04b3db297b.tar.bz2
ayatana-indicator-display-e66c68e2420ed2e2b4ce531dea46dc04b3db297b.zip
Fix failing build
- src/rotation-lock.cpp: Fix double declaration of create_desktop_menu - tests/CMakeLists.txt: Add uninitDerivedMemberVar and unmatchedSuppression suppressions to cppcheck - tests/unit/rotation-lock-test.cpp: Fix and expand test fixes https://github.com/AyatanaIndicators/ayatana-indicator-display/issues/24
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ecd7705..76ebd56 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -29,7 +29,7 @@ endif()
add_compile_options(${CXX_WARNING_ARGS})
-add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem)
+add_test(cppcheck cppcheck --enable=all -USCHEMA_DIR --error-exitcode=2 --inline-suppr --library=qt -I${CMAKE_SOURCE_DIR} -i${CMAKE_SOURCE_DIR}/tests/utils/qmain.cpp -i${CMAKE_SOURCE_DIR}/tests/gmock ${CMAKE_SOURCE_DIR}/src ${CMAKE_SOURCE_DIR}/tests --suppress=missingIncludeSystem --suppress=uninitDerivedMemberVar --suppress=unmatchedSuppression)
add_subdirectory(integration)
add_subdirectory(unit)