aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-09-09 04:56:35 +0200
committerRobert Tari <robert@tari.in>2022-09-09 04:56:35 +0200
commit41950dead1f4688aca7a4ed54fffff027f47989d (patch)
tree3e6485f599502cb7e5ec50e4586a87bde3257424 /tests/unit/CMakeLists.txt
parent5d0960ecabb0c4b0f8cdc5f9959065e392d7f668 (diff)
parent6805522e19162e895a099fb0bd5b417e49d9032c (diff)
downloadayatana-indicator-display-41950dead1f4688aca7a4ed54fffff027f47989d.tar.gz
ayatana-indicator-display-41950dead1f4688aca7a4ed54fffff027f47989d.tar.bz2
ayatana-indicator-display-41950dead1f4688aca7a4ed54fffff027f47989d.zip
Merge branch 'sunweaver-pr/update-and-fix-translations'
Attributes GH PR #57: https://github.com/AyatanaIndicators/ayatana-indicator-display/pull/57
Diffstat (limited to 'tests/unit/CMakeLists.txt')
-rw-r--r--tests/unit/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/unit/CMakeLists.txt b/tests/unit/CMakeLists.txt
index 7d42693..930eb70 100644
--- a/tests/unit/CMakeLists.txt
+++ b/tests/unit/CMakeLists.txt
@@ -12,7 +12,7 @@ set_source_files_properties (gschemas.compiled GENERATED)
# and help the tests to find that file by setting -DSCHEMA_DIR
set (XDG_DATA_DIRS "${CMAKE_CURRENT_BINARY_DIR}/gsettings-schemas")
set (SCHEMA_DIR "${XDG_DATA_DIRS}/glib-2.0/schemas")
-set (DISPLAY_SCHEMA ${CMAKE_BINARY_DIR}/data/org.ayatana.display.gschema.xml)
+set (DISPLAY_SCHEMA ${CMAKE_BINARY_DIR}/data/org.ayatana.indicator.display.gschema.xml)
add_definitions(-DSCHEMA_DIR="${SCHEMA_DIR}")
execute_process (COMMAND ${PKG_CONFIG_EXECUTABLE} gio-2.0 --variable glib_compile_schemas
OUTPUT_VARIABLE COMPILE_SCHEMA_EXECUTABLE
@@ -23,7 +23,7 @@ execute_process (COMMAND ${PKG_CONFIG_EXECUTABLE} gio-2.0 --variable glib_compil
# https://discourse.cmake.org/t/race-condition-when-multi-add-custom-target-deps-on-same-file-generated-by-add-custom-command/2358
# https://bugs.debian.org/892091 (bug for ayatana-indicators-power, but applies here as well)
add_custom_command (OUTPUT gschemas.compiled
- DEPENDS ${CMAKE_BINARY_DIR}/data/org.ayatana.display.gschema.xml
+ DEPENDS ${CMAKE_BINARY_DIR}/data/org.ayatana.indicator.display.gschema.xml
COMMAND mkdir -p ${SCHEMA_DIR}
COMMAND cp -f ${DISPLAY_SCHEMA} ${SCHEMA_DIR}
COMMAND ${COMPILE_SCHEMA_EXECUTABLE} ${SCHEMA_DIR})