aboutsummaryrefslogtreecommitdiff
path: root/tests/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-04-20 19:57:03 -0500
committerCharles Kerr <charles.kerr@canonical.com>2016-04-20 19:57:03 -0500
commite1c1a9ae367c53561cdb4f53ad8589e2bc859b0b (patch)
treef30b37f8a46d4b3ba7b9acda7514ce6dd067f036 /tests/unit/CMakeLists.txt
parente1284eb774d75f96d61787f116b0d79328b27286 (diff)
downloadayatana-indicator-display-e1c1a9ae367c53561cdb4f53ad8589e2bc859b0b.tar.gz
ayatana-indicator-display-e1c1a9ae367c53561cdb4f53ad8589e2bc859b0b.tar.bz2
ayatana-indicator-display-e1c1a9ae367c53561cdb4f53ad8589e2bc859b0b.zip
add unit tests for greeter
Diffstat (limited to 'tests/unit/CMakeLists.txt')
-rw-r--r--tests/unit/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/unit/CMakeLists.txt b/tests/unit/CMakeLists.txt
index fe70461..9d8cad2 100644
--- a/tests/unit/CMakeLists.txt
+++ b/tests/unit/CMakeLists.txt
@@ -14,6 +14,10 @@ set(TEST_LINK_LIBRARIES
${GMOCK_LIBRARIES}
)
+add_definitions(
+ -DGREETER_TEMPLATE="${CMAKE_SOURCE_DIR}/tests/utils/mock-unity-greeter.py"
+)
+
function(add_test_by_name name)
set(TEST_NAME ${name})
add_executable (${TEST_NAME} ${TEST_NAME}.cpp)
@@ -31,4 +35,5 @@ function(add_qt_test_by_name name)
set_property(TEST ${TEST_NAME} APPEND PROPERTY ENVIRONMENT ${CTEST_ENVIRONMENT})
target_link_libraries(${TEST_NAME} ${SERVICE_LINK_LIBRARIES} ${QT_LINK_LIBRARIES} ${TEST_LINK_LIBRARIES} ${THREAD_LINK_LIBRARIES})
endfunction()
+add_qt_test_by_name(greeter-test)
add_qt_test_by_name(usb-snap-test)