aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34fda26..c80a7e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-project(ayatana-indicator-display LANGUAGES C CXX)
cmake_minimum_required(VERSION 3.13)
+project(ayatana-indicator-display VERSION 24.4.0 LANGUAGES C CXX)
if(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
SET(CMAKE_INSTALL_PREFIX "/usr" CACHE PATH "..." FORCE)
@@ -10,7 +10,6 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
##
include(GNUInstallDirs)
-set(PROJECT_VERSION "22.9.1")
set(PACKAGE ${CMAKE_PROJECT_NAME})
set(SERVICE_LIB ${PACKAGE})
set(SERVICE_EXEC "${PACKAGE}-service")
@@ -20,6 +19,7 @@ set(SERVICE_EXEC "${PACKAGE}-service")
option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
+option(ENABLE_COLOR_TEMP "Include colour temperature specific code in the build" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -65,10 +65,11 @@ find_package(PkgConfig REQUIRED)
# glib...
set(GLIB_MINIMUM 2.36)
-set (SERVICE_DEPS libayatana-common>=0.9.3 gio-unix-2.0>=${GLIB_MINIMUM} glib-2.0>=${GLIB_MINIMUM} gudev-1.0)
+set (SERVICE_DEPS libayatana-common>=0.9.3 gio-unix-2.0>=${GLIB_MINIMUM} glib-2.0>=${GLIB_MINIMUM} properties-cpp>=0.0.1)
-if (ENABLE_TESTS)
- list (APPEND SERVICE_DEPS properties-cpp>=0.0.1)
+if (ENABLE_COLOR_TEMP)
+ list (APPEND SERVICE_DEPS libgeoclue-2.0 accountsservice)
+ add_definitions (-DCOLOR_TEMP_ENABLED)
endif ()
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})
@@ -115,3 +116,4 @@ endif()
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")
+message(STATUS "Build with colour temperature code: ${ENABLE_COLOR_TEMP}")