aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt30
1 files changed, 14 insertions, 16 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index eb736c8..2788440 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,26 +1,24 @@
add_definitions(-DG_LOG_DOMAIN="${CMAKE_PROJECT_NAME}")
-if(EXISTS "/usr/share/glib-2.0/schemas/com.ubuntu.sound.gschema.xml")
- add_definitions( -DHAS_UBUNTU_TOUCH_SCHEMA )
-endif()
-
add_compile_options(
${CXX_WARNING_ARGS}
)
-add_library(
- ${SERVICE_LIB}
- STATIC
- adbd-client.cpp
- exporter.cpp
- greeter.cpp
- indicator.cpp
- rotation-lock.cpp
- usb-manager.cpp
- usb-monitor.cpp
- usb-snap.cpp
+set (SERVICE_LIB_SOURCES
+ exporter.cpp
+ indicator.cpp
+ service.cpp
)
+if (ENABLE_COLOR_TEMP)
+ list (APPEND
+ SERVICE_LIB_SOURCES
+ solar.c
+ )
+endif ()
+
+add_library (${SERVICE_LIB} STATIC ${SERVICE_LIB_SOURCES})
+
add_executable(
${SERVICE_EXEC}
main.cpp
@@ -35,5 +33,5 @@ target_link_libraries(${SERVICE_EXEC}
install(
TARGETS
${SERVICE_EXEC}
- RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR}
+ RUNTIME DESTINATION "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}"
)