aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt24
1 files changed, 13 insertions, 11 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b7e91aa..2788440 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -4,19 +4,21 @@ add_compile_options(
${CXX_WARNING_ARGS}
)
-add_library(
- ${SERVICE_LIB}
- STATIC
- adbd-client.cpp
- exporter.cpp
- greeter.cpp
- indicator.cpp
- rotation-lock.cpp
- usb-manager.cpp
- usb-monitor.cpp
- usb-snap.cpp
+set (SERVICE_LIB_SOURCES
+ exporter.cpp
+ indicator.cpp
+ service.cpp
)
+if (ENABLE_COLOR_TEMP)
+ list (APPEND
+ SERVICE_LIB_SOURCES
+ solar.c
+ )
+endif ()
+
+add_library (${SERVICE_LIB} STATIC ${SERVICE_LIB_SOURCES})
+
add_executable(
${SERVICE_EXEC}
main.cpp