aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-10-10 01:08:26 +0200
committerRobert Tari <robert@tari.in>2023-10-10 01:08:56 +0200
commita92d37c1c01bbe7da46ce093ae61ee1bf3ef426b (patch)
treeed3caf67124ba92bae42dcd0f1aacb13ecca418f /CMakeLists.txt
parentf7afd4175d6dc6acc64ac33ffabe716a183195d5 (diff)
downloadayatana-indicator-keyboard-a92d37c1c01bbe7da46ce093ae61ee1bf3ef426b.tar.gz
ayatana-indicator-keyboard-a92d37c1c01bbe7da46ce093ae61ee1bf3ef426b.tar.bz2
ayatana-indicator-keyboard-a92d37c1c01bbe7da46ce093ae61ee1bf3ef426b.zip
CMakeLists.txt: Drop test options
fixes https://github.com/AyatanaIndicators/ayatana-indicator-keyboard/issues/46
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 1 insertions, 23 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c14e2e3..861309ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,16 +8,9 @@ endif(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
# Options
-option(ENABLE_TESTS "Enable all tests and checks" OFF)
-option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
-if(ENABLE_COVERAGE)
- set(ENABLE_TESTS ON)
- set(CMAKE_BUILD_TYPE "Coverage")
-else()
- set(CMAKE_BUILD_TYPE "Release")
-endif()
+set(CMAKE_BUILD_TYPE "Release")
if(ENABLE_WERROR)
add_definitions("-Werror")
@@ -56,21 +49,6 @@ add_subdirectory(src)
add_subdirectory(data)
add_subdirectory(po)
-# Test and coverage
-if (ENABLE_TESTS)
-
- include(CTest)
- enable_testing()
-
- if (ENABLE_COVERAGE)
-
- find_package(CoverageReport)
-
- endif()
-
-endif()
-
# Display config info
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
-message(STATUS "Unit tests: ${ENABLE_TESTS}")
message(STATUS "Build with -Werror: ${ENABLE_WERROR}")