aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-03-01 03:48:30 +0100
committerRobert Tari <robert@tari.in>2022-03-01 10:03:25 +0100
commiteb957b75c0071db42967db0a5fa59170bdb0757c (patch)
tree21594059687ca5d4a1361add636d4819e77bff7c /CMakeLists.txt
parent9a730357f567953041964790f04587661eb7b53b (diff)
downloadayatana-indicator-keyboard-eb957b75c0071db42967db0a5fa59170bdb0757c.tar.gz
ayatana-indicator-keyboard-eb957b75c0071db42967db0a5fa59170bdb0757c.tar.bz2
ayatana-indicator-keyboard-eb957b75c0071db42967db0a5fa59170bdb0757c.zip
Read layout information using libxkbcommon
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93671367..0f888526 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,7 @@ add_definitions (-DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}" -DLOCALEDIR="${CMAKE_INS
find_package (PkgConfig REQUIRED)
include (CheckIncludeFile)
include (FindPkgConfig)
-pkg_check_modules(SERVICE_DEPS REQUIRED glib-2.0>=2.36 gio-2.0>=2.36 libayatana-common>=0.9.3)
+pkg_check_modules(SERVICE_DEPS REQUIRED glib-2.0>=2.36 gio-2.0>=2.36 libayatana-common>=0.9.3 xkbcommon>=1.0.3 xkbregistry>=1.0.3)
pkg_check_modules(X11_DEPS REQUIRED x11>=1.6.7 libxklavier>=5.4)
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})