aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-08-09 12:53:07 -0400
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2013-08-09 12:53:07 -0400
commit624b11490965581fc1cc2eb21fdd7f74d065bd4d (patch)
tree971e0110792092dbabb92870498ed09e33e8dd47 /debian/rules
parent0e3bb46532e1858f2cfee808bd66efa225cb2d94 (diff)
parent9d2aacb967186c594cc4582310080a5ce299a022 (diff)
downloadayatana-indicator-keyboard-624b11490965581fc1cc2eb21fdd7f74d065bd4d.tar.gz
ayatana-indicator-keyboard-624b11490965581fc1cc2eb21fdd7f74d065bd4d.tar.bz2
ayatana-indicator-keyboard-624b11490965581fc1cc2eb21fdd7f74d065bd4d.zip
* debian/control:
- Packaging review, add comment to developers. - Fix Vcs-Bzr, Vcs-Browser. - Sort Build-Depends, use trailing commas. - Improve long description. * debian/rules: - Add DPKG_GENSYMBOLS_CHECK_LEVEL = 4. - Override dh_autoreconf to run ./autogen.sh. - Override dh_install to remove .la and .a files. - Run dh_install with --fail-missing. * debian/compat: bump to compat level 9. * debian/source/format: make sure we're using format 1.0.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 13 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index c816d1da..a69660c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,21 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
%:
dh $@ --with autoreconf,translations
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
+ find debian/indicator-keyboard/usr/lib -name *.la -delete
+ find debian/indicator-keyboard/usr/lib -name *.a -delete
+ dh_install --fail-missing
+
+override_dh_auto_test:
+ dh_auto_test || ( cat tests/test-suite.log )