aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 00000000..c0b6a2eb
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,12 @@
+###########################
+# Upstart XDG Override
+###########################
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-keyboard.desktop
+
+%.desktop: %.desktop.in
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+EXTRA_DIST = indicator-keyboard.desktop.in
+