aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 11 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 5da073ca..e7fca45d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,19 +4,22 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-export DPKG_GENSYMBOLS_CHECK_LEVEL=4
-
%:
- dh $@
-
-override_dh_autoreconf:
- NOCONFIGURE=1 ./autogen.sh
+ dh $@ --with systemd
override_dh_install:
- find debian/ayatana-indicator-keyboard/usr/lib -name *.la -delete
- find debian/ayatana-indicator-keyboard/usr/lib -name *.a -delete
+ find debian/ayatana-indicator-keyboard -name \*.la -delete
+ find debian/ayatana-indicator-keyboard -name \*.a -delete
dh_install --fail-missing
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..