aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-09-21 16:10:56 -0500
committerTed Gould <ted@gould.cx>2010-09-21 16:10:56 -0500
commitfa787d7a05cfbe3ff35e04d9a4e8260cbb0e9d06 (patch)
treeb41c58b3e5b397465d607602953dbba82af2be52 /Makefile.am
parente5203a9b365ba1c6ab32fb772c31577350b1c2cd (diff)
downloadayatana-indicator-messages-fa787d7a05cfbe3ff35e04d9a4e8260cbb0e9d06.tar.gz
ayatana-indicator-messages-fa787d7a05cfbe3ff35e04d9a4e8260cbb0e9d06.tar.bz2
ayatana-indicator-messages-fa787d7a05cfbe3ff35e04d9a4e8260cbb0e9d06.zip
Building ChangeLog and AUTHORS from makefile
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 26c2a33..d08c383 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,3 +6,28 @@ SUBDIRS = \
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi