aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-21 10:22:50 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-21 10:22:50 -0500
commit0e5b8f77b3320b12f497153b7a781272aacac00a (patch)
tree9be4ee3de485aff2d10189cbceac8d396eb08460 /configure.ac
parent1985b73f61e084b60ed9f64de78f541f57059f9d (diff)
downloadayatana-indicator-messages-0e5b8f77b3320b12f497153b7a781272aacac00a.tar.gz
ayatana-indicator-messages-0e5b8f77b3320b12f497153b7a781272aacac00a.tar.bz2
ayatana-indicator-messages-0e5b8f77b3320b12f497153b7a781272aacac00a.zip
Reverted r268, restored BUILD_TESTS; ted explains upstream arch patch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a5ca692..a429d17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,15 @@ AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
###########################
+# Test Dependencies
+###########################
+
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable test scripts and tools]),,
+ [enable_tests=auto])
+AM_CONDITIONAL(BUILD_TESTS, test xyes = xyes)
+
+###########################
# Status Provider Deps
###########################
@@ -117,7 +126,6 @@ AC_SUBST(COVERAGE_LDFLAGS)
m4_include([m4/gtest.m4])
CHECK_GTEST
-AM_CONDITIONAL([HAVE_GTEST], [test "x$have_gtest" = xyes])
###########################
# Check to see if we're local