aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-20 16:36:08 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-20 16:36:08 -0500
commit4700a77b61efa6bb089d019223177e47cdc5c3db (patch)
tree9c4f0fed3f679d8aa7497e2d0500106787bade03 /configure.ac
parentf7d971a8407224ddd8b1b8744d18a33032c9142d (diff)
downloadayatana-indicator-messages-4700a77b61efa6bb089d019223177e47cdc5c3db.tar.gz
ayatana-indicator-messages-4700a77b61efa6bb089d019223177e47cdc5c3db.tar.bz2
ayatana-indicator-messages-4700a77b61efa6bb089d019223177e47cdc5c3db.zip
Charles-suggested fixes for gmodule dependency.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5ec945a..1690ad6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,7 +59,8 @@ AS_IF([test "x$with_gtk" = x3],
indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
indicate-0.7 >= $INDICATE_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- glib-2.0 >= $GLIB_REQUIRED_VERSION)
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gmodule-2.0 >= $GLIB_REQUIRED_VERSION)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
@@ -67,7 +68,8 @@ AS_IF([test "x$with_gtk" = x3],
indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
indicate-0.7 >= $INDICATE_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- glib-2.0 >= GLIB_REQUIRED_VERSION)
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gmodule-2.0 >= $GLIB_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-indicator-gtk was neither 2 nor 3])]
)