aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2011-12-06 18:51:58 -0600
committerAllan LeSage <allanlesage@gmail.com>2011-12-06 18:51:58 -0600
commit4f5f1e3ea9317f37e55028631f493f4a709cd8a5 (patch)
tree6b50cb4d0c2d51f6e80095e76aaff69a890d92da /configure.ac
parentde9314480fa9df8b5c7ab30f0e013205fc46347c (diff)
downloadayatana-indicator-messages-4f5f1e3ea9317f37e55028631f493f4a709cd8a5.tar.gz
ayatana-indicator-messages-4f5f1e3ea9317f37e55028631f493f4a709cd8a5.tar.bz2
ayatana-indicator-messages-4f5f1e3ea9317f37e55028631f493f4a709cd8a5.zip
Added coverage reporting via gcov config and targets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 67445d5..46f36ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,6 +91,16 @@ AC_SUBST(STATUS_PROVIDER_EMESENE_CFLAGS)
AC_SUBST(STATUS_PROVIDER_EMESENE_LIBS)
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -191,4 +201,5 @@ Messaging Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
+ gcov: $use_gcov
])