aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2013-02-25 19:34:56 -0500
committerLars Uebernickel <lars.uebernickel@canonical.com>2013-02-25 19:34:56 -0500
commit5c47f6dbe75e413d2acbcef3e9750e937fb18431 (patch)
treefce3bfab963100972280fe4d61df903c5e20c7db /configure.ac
parent8249e264e0f426d6702d21a690477be495045f90 (diff)
downloadayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.tar.gz
ayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.tar.bz2
ayatana-indicator-messages-5c47f6dbe75e413d2acbcef3e9750e937fb18431.zip
Test libmessaging-menu
Use dbusmock to test whether libmessaging-menu calls the right functions on registration and deregistration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index bcd7b20..08ac680 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,7 +75,7 @@ AC_SUBST(COVERAGE_CXXFLAGS)
AC_SUBST(COVERAGE_LDFLAGS)
###########################
-# Google Test framework
+# Tests
###########################
AC_ARG_ENABLE([tests],
@@ -85,10 +85,16 @@ AC_ARG_ENABLE([tests],
if test "x$enable_tests" != "xno"; then
m4_include([m4/gtest.m4])
CHECK_GTEST
- if test "x$enable_tests" = "xauto"; then
- enable_tests=${have_gtest}
- elif test "x$enable_tests" = "xyes" && test "x$have_gtest" != "xyes"; then
- AC_MSG_ERROR([tests were requested but gtest is not installed.])
+ AM_PATH_PYTHON(3.0,, [:])
+ AC_PYTHON_MODULE(dbusmock)
+ if test "x$have_gtest" = "xyes" -a "x$HAVE_PYMOD_DBUSMOCK" = "xyes"; then
+ enable_tests="yes"
+ else
+ if test "x$enable_tests" = "xyes"; then
+ AC_MSG_ERROR([tests were requested but gtest or dbusmock are not installed.])
+ else
+ enable_tests="no"
+ fi
fi
fi
AM_CONDITIONAL([BUILD_TESTS],[test "x$enable_tests" = "xyes"])
@@ -193,7 +199,7 @@ Messaging Indicator Configuration:
Prefix: $prefix
Indicator Dir: $INDICATORDIR
- gtest: $enable_tests
+ tests: $enable_tests
gcov: $use_gcov
introspecion: $enable_introspection
documentation: $enable_gtk_doc