aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Terry <mike@mterry.name>2010-10-06 14:58:05 -0400
committerMichael Terry <mike@mterry.name>2010-10-06 14:58:05 -0400
commit687ea648b9a8fd6e39ec0da306f4440c3f39f694 (patch)
treeba68f1aeebc094848d2b9ce52f5d19ff05624bd2 /configure.ac
parentfa787d7a05cfbe3ff35e04d9a4e8260cbb0e9d06 (diff)
downloadayatana-indicator-messages-687ea648b9a8fd6e39ec0da306f4440c3f39f694.tar.gz
ayatana-indicator-messages-687ea648b9a8fd6e39ec0da306f4440c3f39f694.tar.bz2
ayatana-indicator-messages-687ea648b9a8fd6e39ec0da306f4440c3f39f694.zip
avoid deprecated API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f41aff0..8f533db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,15 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+AC_ARG_ENABLE([deprecations],
+ [AS_HELP_STRING([--enable-deprecations],
+ [allow deprecated API usage @<:@default=yes@:>@])],
+ [],
+ [enable_deprecations=yes])
+AS_IF([test "x$enable_deprecations" = xno],
+ [CFLAGS="$CFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGSEAL_ENABLE -DGTK_DISABLE_SINGLE_INCLUDES"]
+)
+
###########################
# Dependencies
###########################