aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-08 11:40:38 -0500
committerTed Gould <ted@gould.cx>2011-07-08 11:40:38 -0500
commit7a1cef803be9893e30d6e4e9ba4147e43cf38319 (patch)
tree5ea6c80addd1e0e65f4a3940f34b181d250ab5c5 /configure.ac
parent357324760c1d7391276a25a83ecd1f83bea9aa7b (diff)
parent9fd47d873b3f30ad803b1655eba9449d34ff09ff (diff)
downloadayatana-indicator-messages-7a1cef803be9893e30d6e4e9ba4147e43cf38319.tar.gz
ayatana-indicator-messages-7a1cef803be9893e30d6e4e9ba4147e43cf38319.tar.bz2
ayatana-indicator-messages-7a1cef803be9893e30d6e4e9ba4147e43cf38319.zip
Getting libindicator 0.4 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9638b7e..95868b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_INIT(src/indicator-messages.c)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-messages, 0.4.90)
+AM_INIT_AUTOMAKE(indicator-messages, 0.4.91)
AM_MAINTAINER_MODE
@@ -52,14 +52,14 @@ AC_ARG_WITH([indicator-gtk],
AS_IF([test "x$with_indicator_gtk" = x3],
[PKG_CHECK_MODULES(APPLET, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
- indicator3 >= $INDICATOR_REQUIRED_VERSION
+ indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
indicate-0.5 >= $INDICATE_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
],
[test "x$with_indicator_gtk" = x2],
[PKG_CHECK_MODULES(APPLET, gtk+-2.0 >= $GTK_REQUIRED_VERSION
gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION
- indicator >= $INDICATOR_REQUIRED_VERSION
+ indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
indicate-0.5 >= $INDICATE_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
],
@@ -105,11 +105,11 @@ if test "x$with_localinstall" = "xyes"; then
INDICATORDIR="${libdir}/indicators/2/"
INDICATORICONSDIR="${datadir}/libindicate/icons/"
elif test "x$with_indicator_gtk" = x2; then
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator-0.4`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator-0.4`
else
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3`
+ INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`
fi
AC_SUBST(INDICATORDIR)
AC_SUBST(INDICATORICONSDIR)