aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-15 11:30:13 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-15 11:30:13 -0500
commitb11161a7ffab99f5415e4136ce9ddd0bf6e1fa76 (patch)
tree630885ec100a91e14714db799c00d128d8a32a77 /configure.ac
parent7c4783ff8593aa4d99c0f741e45438ab7b1ca2f9 (diff)
downloadayatana-indicator-messages-b11161a7ffab99f5415e4136ce9ddd0bf6e1fa76.tar.gz
ayatana-indicator-messages-b11161a7ffab99f5415e4136ce9ddd0bf6e1fa76.tar.bz2
ayatana-indicator-messages-b11161a7ffab99f5415e4136ce9ddd0bf6e1fa76.zip
Dummy commit on 'no rule' err.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 159c740..a85773d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,9 @@ AS_IF([test "x$enable_deprecations" = xno],
[CFLAGS="$CFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGSEAL_ENABLE -DGTK_DISABLE_SINGLE_INCLUDES"]
)
+# the Google Test targets are cpp
+AC_PROG_CXX
+
###########################
# Dependencies
###########################
@@ -69,6 +72,15 @@ AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
###########################
+# Test Dependencies
+###########################
+
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable test scripts and tools]),,
+ [enable_tests=auto])
+AM_CONDITIONAL(BUILD_TESTS, test xyes = xyes)
+
+###########################
# Status Provider Deps
###########################
@@ -104,6 +116,13 @@ AC_SUBST(COVERAGE_CXXFLAGS)
AC_SUBST(COVERAGE_LDFLAGS)
###########################
+# Google Test framework
+###########################
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+
+###########################
# Check to see if we're local
###########################
@@ -192,6 +211,7 @@ data/icons/scalable/Makefile
data/icons/scalable/status/Makefile
data/icons/scalable/categories/Makefile
po/Makefile.in
+test/Makefile
])
###########################